Installation

Check dependencies

You only need NumPy, SciPy for the package and additionally scikit-learn if you would like to run the examples. We recommend Python >= 2.6, scikit-learn >= 0.17, NumPy >= 1.6.1 and SciPy >= 0.14.

Both Canopy and Anaconda ship with a recent version of all these packages.

In case you have other distributions of Python, you can install NumPy and SciPy using pip.

pip install numpy
pip install scipy

To install scikit-learn follow these installation instructions.

Get pyglmnet

If you would like to install the latest stable release:

pip install pyglmnet

To install the development version of pyglmnet, first clone the repository

git clone http://github.com/glm-tools/pyglmnet

Then run setup.py to install the library

cd pyglmnet
python setup.py develop install